Announcement

Collapse
No announcement yet.

Alignment?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ryejeff
    replied
    Agreed. Jeff does great work.

    Leave a comment:


  • crouse
    replied
    Thank you, Curt.

    Leave a comment:


  • the tick
    replied
    He's in Hopkins, he's a great guy, and does great work!

    Leave a comment:


  • haroldk
    replied
    He schedules by email exclusively. [email protected]

    Leave a comment:


  • crouse
    replied
    Who is Jeff The Alignment Guy here? I'd like to see about bringing my car to him to verify it has the proper alignment.

    Leave a comment:


  • the tick
    replied
    Originally posted by crouse View Post
    I can't remember when it started. I think it's just been a gradual change. I'll poke around underneath this weekend to see if I can see anything bad. You'd think Apple Valley Ford would have said something if the tie rod ends or ball joints were bad.
    They would certainly love to have your money, but don't assume the tech working on your car was digging in that deep....

    Leave a comment:


  • crouse
    replied
    I can't remember when it started. I think it's just been a gradual change. I'll poke around underneath this weekend to see if I can see anything bad. You'd think Apple Valley Ford would have said something if the tie rod ends or ball joints were bad.

    Leave a comment:


  • 73GT
    replied
    Also look at the inner tie rods on the rack

    Leave a comment:


  • the tick
    replied
    Is this a new development? If so; a) when do you notice it start, and b) did you anything at that time?

    If nothing has changed (no alignment change, no tire change, no parts change, no pothole hits), I would look at ball joints, tie rod ends, maybe play in the steering rack/steering rack mounts & bolts.

    Leave a comment:


  • crouse
    started a topic Alignment?

    Alignment?

    I noticed that my 2003 Mercury Marauder wants to hunt when crossing from one lane to another or when moving to a turn lane where there is a grove between the lanes. If I move from the right to left lane, it pulls me to the left as the left tire crosses the grove between the right and left lane. Then when the right tire crossed the grove, it pulls me back to the right. So I had Apple Valley Ford do a front end alignment thinking it was toed out too much. The alignment didn't make any improvement. They didn't say anything about ball joints or tie rod ends. In fact, I was surprises they didn't call me telling me these were bad. I have about 125k miles on it. The front tires are Nitto NT555 G2 255/45-18 that have good tread on them and I run them at about 32 PSI. Any thoughts on what might cause this hunting?
Working...
X